Comment puis-je installer Cinnamon sur Ubuntu 12.04 et éliminer les erreurs suivantes:

$ sudo apt-get install cinnamon cinnamon-session cinnamon-settings Reading package lists... Done Building dependency tree Reading state information... Done Note, selecting 'cinnamon' instead of 'cinnamon-session' Note, selecting 'cinnamon' instead of 'cinnamon-settings' Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable dissortingbution that some required packages have not yet been created or been moved out of Incoming. The following information may help resolve the situation: The following packages have unmet dependencies: cinnamon : Depends: gir1.2-muffin-3.0 but it is not going to be installed Depends: libcogl5 (>= 1.7.4) but it is not installable Depends: libmuffin0 (>= 1.0.0-0ubuntu1~precise) but it is not going to be installed Recommends: gnome-themes-standard but it is not going to be installed Recommends: gnome-session-fallback but it is not going to be installed E: Unable to correct problems, you have held broken packages. 

J’ai ajouté ce PPA:

sudo add-apt-repository ppa:merlwiz79/cinnamon-ppa

Puis a lancé la commande suivante:

sudo apt-get update && sudo apt-get install cinnamon cinnamon-session cinnamon-settings

Comment puis-je installer le dernier ordinateur de bureau Cinnamon? Comment puis-je réparer cette erreur?

Ce PPA ne contient pas la dernière version de Cinnamon. Il est relativement ancien étant donné le rythme de développement rapide et le mainteneur n’a pas (encore) mis à jour ce PPA.

En tant que tel, je vous recommanderais de purger le PPA et d’installer la dernière version conformément à ce Q & A:

  • Comment installer le bureau Cinnamon?

comment

Installer ppa-purge

 sudo apt-get install ppa-purge 

La purge le ppa:

 sudo apt-get -f install sudo ppa-purge ppa:ppa:merlwiz79/cinnamon-ppa sudo apt-get update 

C’est un problème étrange. Habituellement, apt-get installe automatiquement toutes les dépendances nécessaires pour un paquet. Vous devez exécuter sudo apt-get installer cannelle cannelle-parameters cinnamon-theme libmuffin0 gir1.2-muffin-3.0 libcogl5 pour installer Cinnamon.

C’est un problème de dépendance des paquets.

Tapez ceux-ci dans le terminal:

 sudo apt-get install gir1.2-muffin-3.0 libcogl5 libmuffin0 

et redémarrez puis installez Cinnamon.

Si vous ne parvenez toujours pas à installer Cinnamon, je vous recommande d’installer GNOME 3. Cela n’aide peut-être pas, mais après avoir installé GNOME 3 Cinnamon, j’ai travaillé (j’ai eu le même problème).

 sudo add-apt-repository ppa:gnome3-team/gnome3 sudo apt-get update sudo apt-get install gnome-shell 

Puis réinstallez Cinnamon.