snappy ubuntu core installer les packages de base

Comment installer le paquet de base sur le kernel Ubuntu, comme nano git wget, etc.

J’ai essayé le dpkg -i ***.deb , mais il y a aussi besoin de paquets dépendants

La solution de contournement publiée par Lin convient parfaitement le 15.04, mais dans 16.04 LTS, vous aurez un mécanisme différent, appelé “dimension classique”, qui vous donnera un système de fichiers traditionnel basé sur deb en plus des systèmes de fichiers rapides. De cette façon, vous pouvez utiliser Git ou d’autres outils sur un système accrocheur et naviguer entre les dimensions simples et classiques.

Si aucun composant logiciel enfichable de ce type n’est disponible (recherchez-le avec snappy search NAME ), vous devrez l’installer avec le package .deb. Et vous devrez également installer tous les autres packages nécessaires.

Par exemple, si vous voulez installer git dessus, vous aurez besoin des paquets suivants:

 git-man (>> 1:2.1.4) git-man (<< 1:2.1.4-.) libc6 (>= 2.16) libcurl3-gnutls (>= 7.16.2) liberror-perl libexpat1 (>= 2.0.1) libpcre3 perl-modules zlib1g (>= 1:1.2.0) 

(liberror-perl dépend de perl , vous en aurez également besoin)

Vous pouvez trouver la dépendance dans la section “Relations de paquet” de la page de projet git dans le tableau de bord . Il vous suffit de télécharger tous ces paquets .deb et de les mettre sur votre système:

 (amd64) ubuntu @ localhost: ~ / git $ ls
 git-man_2.1.4-2.1_all.deb liberror-perl_0.17-1.1_all.deb perl_5.20.2-2_amd64.deb
 git_2.1.4-2.1_amd64.deb libexpat1_2.1.0-6ubuntu1.1_amd64.deb zlib1g_1.2.8.dfsg-2ubuntu1_amd64.deb
 libc6_2.21-0ubuntu4_amd64.deb libpcre3_8.35-3.3ubuntu1.1_amd64.deb
 libcurl3-gnutls_7.38.0-3ubuntu2.2_amd64.deb perl-modules_5.20.2-2_all.deb

Et installez-les sur votre Ubuntu Core:

sudo mount -o remount,rw /; sudo dpkg -i *.deb

C’est tout!

 (amd64)ubuntu@localhost:~/git$ git --version git version 2.1.4